Conversions - Unable to Return Leads
Incident Report for Integrate
Resolved
This issue has been confirmed to be fixed by the customer and is now resolved.
Posted Dec 15, 2022 - 17:29 GMT
Investigating
We are currently investigating this issue.
Posted Dec 15, 2022 - 17:24 GMT