Delays processing business cards
Incident Report for Integrate Events
Resolved
This incident has been resolved.
Posted Oct 12, 2018 - 12:04 BST
Monitoring
We're currently experiencing a high load due to a large number of events, which means that business cards may take a little longer than usual to be transcribed.
Posted Oct 09, 2018 - 13:44 BST
This incident affected: Integrate Events - Business Card Processing.